technical support A&H Xone 42/monitors

- open
Youloo
Posts: 3
Joined: Mon Jul 23, 2012 7:05 am

Re: technical support A&H Xone 42/monitors

Post by Youloo » Thu Sep 27, 2012 10:07 am

Sack off Allen and Grief altogether and get yourself an Ecler mixer.

pastapiu
mnml mmbr
mnml mmbr
Posts: 159
Joined: Sun Feb 05, 2012 6:31 pm
Location: Amsterdam
Contact:

Re: technical support A&H Xone 42/monitors

Post by pastapiu » Tue Oct 02, 2012 12:42 pm

Oooe those Ecler mixers look tight, don't have the money for that though. Although the story below isn't in favor of A&H nor Thomann.de webshop.

I had a guy to look at the mixer and it seemed that someone had already been fizzling with the mixer while I had bought it 'new' from Thomann. The strip of the 4th channel was not properly welded and another strip was reversed.. Also some plastic had melted due to somebody who had been soldering in the mixer (and didn't even do it properly). Those f**kers seem to have sent me a broken and fixed mixer.

However, it got fixed, I went home and plugged it in, still had the same problem. So I fixed some other elements and tried those. This resulted in sound coming from both the monitors! I assumed it was practically impossible for those Ortofon's to have been the problem as it would have been both elements that were 'broken'. But it seems that this, besides the mixer, being a part of the problem. Could it be that they had some sort of an electricity peak or something, that they only give signal to one monitor? Thanks again for the help!

Erik

pastapiu
mnml mmbr
mnml mmbr
Posts: 159
Joined: Sun Feb 05, 2012 6:31 pm
Location: Amsterdam
Contact:

Re: technical support A&H Xone 42/monitors

Post by pastapiu » Tue Oct 02, 2012 12:43 pm

At least now I can mix again :)

Post Reply